Dashboard unavailable

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Apr 03, 2026 - 11:20 UTC

Monitoring

We have identified the issue and have a fix in place.
Posted Apr 03, 2026 - 11:08 UTC

Investigating

The dashboard is currently unavailable and we are investigating this issue.
Posted Apr 03, 2026 - 10:50 UTC
This incident affected: Dashboard.