Brex.com minor outage

Incident Report for Brex

Resolved

We have identified the issue with Home Page. We are working to resolve it and will provide updates here as we work on a fix.
Posted 10 months ago. Jun 04, 2024 - 17:35 UTC

Identified

Some customers are experiencing an issue with Brex.com crashing on navigation. We are investigating and will update this page as we resolve the issue.
Posted 10 months ago. Jun 04, 2024 - 17:33 UTC
This incident affected: Home Page.