Some dashboard tables and views show incorrect data when filtered

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Mar 27, 2026 - 14:32 UTC

Monitoring

We've identified the issue and this is now resolved. We are continuing to monitor.
Posted Mar 26, 2026 - 15:13 UTC

Investigating

Duplicate bill payments are showing up in the bills page
Posted Mar 26, 2026 - 14:45 UTC
This incident affected: Bill Pay.