Some customers are unable to view the Brex Dashboard
Incident Report for Brex
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 19:11 UTC
Monitoring
Some customers were experiencing an issue with loading the Brex Dashboard. We are monitoring our fix and will update this page as we resolve the issue.
Posted Nov 27, 2024 - 18:24 UTC
This incident affected: Dashboard.