Dashboard interruption

Incident Report for Brex

Resolved

Dashboard access has been restored for all users.
Posted Jun 25, 2025 - 23:43 UTC

Monitoring

We are currently monitoring issues with the Brex Dashboard. Mobile and card transactions are unaffected.
Posted Jun 25, 2025 - 23:34 UTC