Sending money via international wire in non-USD currencies is unavailable

Incident Report for Brex

Resolved

The issue when sending money or paying a bill via international wire in non-USD currencies has been resolved.
Posted Nov 01, 2025 - 22:03 UTC

Update

Sending money via international wire in non-USD currencies is unavailable
Posted Nov 01, 2025 - 20:59 UTC

Identified

Sending money via international wire in non-USD currencies is unavailable
Posted Nov 01, 2025 - 20:06 UTC
This incident affected: Bill Pay and Banking.