Column wire settlement delays

Incident Report for Brex

Resolved

This issue is now fully resolved
Posted Oct 03, 2025 - 20:38 UTC

Monitoring

We’ve mitigated the issue causing delays in treasury and wire transfers and will continue monitoring
Posted Oct 03, 2025 - 16:58 UTC

Update

We are currently investigating an issue causing delays in treasury and wire transfers.
Posted Oct 03, 2025 - 15:05 UTC

Investigating

We are currently investigating an issue causing delays in treasury and wire transfers.
Posted Oct 03, 2025 - 14:52 UTC
This incident affected: Bill Pay.