Some users can't sign in with Firefox

Incident Report for Brex

Resolved

A fix was implemented and customers are now able to sign in.
Posted Jun 04, 2025 - 16:09 UTC

Investigating

We identified that there are some users with difficulties logging in to the Dashboard while using Firefox.
Posted Jun 03, 2025 - 19:54 UTC
This incident affected: Authentication.