Service Availability
Incident Report for Brex
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 12:46 UTC
Investigating
Some customers are experiencing an issue with Cash, APIs, Dashboard, Card, and Mobile. We are investigating and will update this page as we resolve the issue.
Posted Sep 09, 2022 - 12:20 UTC
This incident affected: Card, APIs, Dashboard, Mobile, and Cash.