Cloudflare Outage

Incident Report for Brex

Resolved

We experienced an outage affecting chat support, receipt processing and address verification due to an outage by one of our partners, Cloudflare. This has now been resolved.
Posted Nov 18, 2025 - 17:53 UTC

Monitoring

Chat support may not be accessible for some users, but phone support is available. This was caused by an ongoing Cloudflare outage, and our team is monitoring as service is being restored.
Posted Nov 18, 2025 - 16:17 UTC
This incident affected: Dashboard, Mobile, and Home Page.