Severe latency in authz choking up most services

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Feb 24, 2026 - 21:16 UTC

Monitoring

We have identified the issue and a fix has been deployed. Errors seem to be recovering and we are continuing to monitor the situation.
Posted Feb 24, 2026 - 20:25 UTC

Investigating

We are currently investigating this issue.
Posted Feb 24, 2026 - 20:21 UTC