Some customers are currently experiencing issues when trying to submit repayments.

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Sep 16, 2025 - 23:20 UTC

Monitoring

We have identified the issue and have a fix in place.
Posted Sep 16, 2025 - 21:24 UTC

Identified

We have identified the issue and are working on a fix.
Posted Sep 16, 2025 - 17:51 UTC

Investigating

We are currently investigating this issue.
Posted Sep 16, 2025 - 17:03 UTC
This incident affected: Spend Management.