Emails to Microsoft inboxes are currently delayed

Incident Report for Brex

Resolved

Emails going to Microsoft-based addresses should now be received in a timely mannner
Posted Jan 23, 2026 - 16:13 UTC

Monitoring

Emails going to Microsoft-based addresses are currently seeing a delay in delivery. Our email vendor is currently investigating.
Posted Jan 22, 2026 - 22:36 UTC