Issues with sending email notifications

Incident Report for Brex

Resolved

SendGrid has confirmed that email delivery should be restored as of 9:08pm PDT yesterday.
Posted Apr 24, 2025 - 12:40 UTC

Monitoring

SendGrid has mitigated their incident and we are monitoring email delivery recovery
Posted Apr 24, 2025 - 00:05 UTC

Identified

We are experiencing issues sending emails to customers as a result of our downstream partner SendGrid.

https://status.sendgrid.com/incidents/6fj45kvpw8n3
Posted Apr 23, 2025 - 21:56 UTC