Dashboard - Bill Pay and Cash Availability
Incident Report for Brex
Resolved
This incident has been resolved.
Posted May 17, 2023 - 01:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2023 - 01:36 UTC
Investigating
Some customers are experiencing an issue loading the Bill Pay and Cash pages in Dashboard. We are investigating and will update this page as we resolve the issue.
Posted May 16, 2023 - 21:50 UTC
This incident affected: Dashboard.