Brex Dashboard and mobile app are unavailable

Incident Report for Brex

Resolved

This incident has been resolved.
Posted 3 days ago. Apr 03, 2025 - 16:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 3 days ago. Apr 03, 2025 - 16:27 UTC

Update

Some actions on the dashboard and the mobile app are recovering but we are still restoring service at this time.
Posted 3 days ago. Apr 03, 2025 - 16:22 UTC

Update

Some customers are experiencing an issue with the Brex Dashboard and the mobile app. Additionally, some customers might be experiencing issues with issuing and using their cards at this time. We are still investigating and will update this page as we resolve the issue.
Posted 3 days ago. Apr 03, 2025 - 15:48 UTC

Update

Some customers are experiencing an issue with the Bresx Dashboard and the mobile app. Additionally, some customers might be experiencing issues with issuing and using their cards at this time. We are still investigating and will update this page as we resolve the issue.
Posted 3 days ago. Apr 03, 2025 - 15:38 UTC

Update

Some customers are experiencing an issue with Dashboard. We are investigating and will update this page as we resolve the issue.
Posted 3 days ago. Apr 03, 2025 - 15:27 UTC

Investigating

Some customers are experiencing an issue with loading the Brex Dashboard. We are investigating and will update this page as we resolve the issue.
Posted 3 days ago. Apr 03, 2025 - 15:24 UTC
This incident affected: Dashboard and Mobile.