Bill Pay Partial Outage

Incident Report for Brex

Resolved

This incident has been resolved.
Posted 6 months ago. Oct 02, 2024 - 20:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Oct 02, 2024 - 19:57 UTC

Investigating

Some customers are experiencing an issue with creating or approving bills. We are investigating and will update this page as we resolve the issue.
Posted 6 months ago. Oct 02, 2024 - 18:04 UTC
This incident affected: Bill Pay.