Users are experiencing errors when viewing spend limit requests

Incident Report for Brex

Resolved

We have identified the root cause and resolved the issue.
Posted Jul 17, 2026 - 15:32 UTC

Investigating

We're investigating reports of errors when trying to view new spend limit or spend limit increase requests in the Tasks page of the Brex dashboard.
Posted Jul 17, 2026 - 14:51 UTC
This incident affected: Spend Management.