Dashboard is down

Incident Report for Brex

Resolved

The issue was resolved
Posted Mar 18, 2026 - 13:40 UTC

Investigating

We are currently investigating this issue.
Posted Mar 18, 2026 - 12:24 UTC
This incident affected: Dashboard.