Issues with Brex Travel
Incident Report for Brex
Resolved
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2024 - 16:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2024 - 16:13 UTC
Identified
Some customers are experiencing an issue with Brex travel. We are investigating and will update this page as we resolve the issue.
Posted Mar 28, 2024 - 16:02 UTC
This incident affected: Brex Travel.