Brex Dashboard and APIs are loading slowly

Incident Report for Brex

Resolved

We are seeing the Dashboard and API latency go back to normal now.
Posted Aug 07, 2025 - 01:42 UTC

Monitoring

We are seeing recovery in performance for loading the Dashboard and our APIs.
Posted Aug 07, 2025 - 01:33 UTC

Update

We are continuing to investigate degraded performance on our Dashboard and APIs.
Posted Aug 07, 2025 - 01:19 UTC

Investigating

We are investigating slow page loads on the Brex Dashboard.
Posted Aug 07, 2025 - 01:12 UTC
This incident affected: Partner API and Dashboard.