Dashboard and Transaction Availability
Incident Report for Brex
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 22:42 UTC
Update
Services have been restored and we are continuing to monitor any further issues.
Posted Jun 12, 2023 - 22:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2023 - 22:28 UTC
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 21:59 UTC
Investigating
Some customers are experiencing an issue with Dashboard and online transactions that require Two Factor Authentication (2FA). We are investigating and will update this page as we resolve the issue.
Posted Jun 12, 2023 - 21:40 UTC
This incident affected: Money movement: card authorization and Dashboard.