Money Movement Services

Incident Report for Brex

Resolved

This incident has been resolved.
Posted 2 years ago. Sep 09, 2023 - 01:51 UTC

Update

A fix has been implemented and we are monitoring the results.
Posted 2 years ago. Sep 09, 2023 - 01:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 2 years ago. Sep 09, 2023 - 01:43 UTC

Investigating

Some users are experiencing an issue with Money Movement services (incorrect approvals and/or declines). We are investigating and will update this page as we resolve the issue.
Posted 2 years ago. Sep 09, 2023 - 00:58 UTC
This incident affected: Money movement: card authorization.