Dashboard unavailable

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Apr 02, 2026 - 16:02 UTC

Monitoring

Dashboard availability has recovered and we are continuing to monitor resolution.
Posted Apr 02, 2026 - 15:18 UTC

Investigating

We are currently investigating this issue.
Posted Apr 02, 2026 - 15:17 UTC
This incident affected: Dashboard.