Dashboard disruption

Incident Report for Brex

Resolved

Functionality has been restored.
Posted Jul 02, 2025 - 15:35 UTC

Monitoring

Functionality has recovered and we are monitoring.
Posted Jul 02, 2025 - 15:24 UTC

Identified

We have identified the root cause and are working to restore functionality.
Posted Jul 02, 2025 - 15:05 UTC

Investigating

Users may be experiencing issues loading the Brex Dashboard. We are currently investigating the issue.
Posted Jul 02, 2025 - 14:41 UTC
This incident affected: Dashboard.