Two factor authentication seeing increased loading time

Incident Report for Brex

Resolved

We have seen latency stabilize.
Posted Apr 02, 2026 - 18:24 UTC

Monitoring

We are seeing latency stabilize and are continuing to monitor
Posted Apr 02, 2026 - 17:52 UTC

Investigating

We are currently investigating an issue with our two factor authentication taking a long time to load.
Posted Apr 02, 2026 - 17:43 UTC
This incident affected: Authentication.