Intermittent errors on the Brex dashboard

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Aug 11, 2026 - 19:12 UTC

Monitoring

We have identified the issue and have a fix in place
Posted Aug 11, 2026 - 18:17 UTC

Update

We have identified the issue and have a fix in place
Posted Aug 11, 2026 - 18:17 UTC

Identified

Our team has identified the issue and are working to restore normal service.
Posted Aug 11, 2026 - 17:51 UTC

Investigating

Customers may experience intermittent issues accessing the Brex dashboard. Our team is investigating and working to restore normal service.
Posted Aug 11, 2026 - 17:16 UTC