Cloudflare Outage

Incident Report for Brex

Resolved

We experienced an outage affecting chat support, receipt processing and address verification due to an outage by one of our partners, Cloudflare. This is now resolved, and our team is monitoring to ensure normal operations.
Posted Nov 18, 2025 - 16:30 UTC

Monitoring

We experienced an outage affecting chat support, receipt processing and address verification due to an outage by one of our partners, Cloudflare. This is now resolved, and our team is monitoring to ensure normal operations.
Posted Nov 18, 2025 - 14:50 UTC

Update

We are unable to provide support via chat, but phone support is available. Other functionality, including receipt processing and address verification are also impacted due to an outage by one of our partners, Cloudflare. Our team is monitoring the issue.
Posted Nov 18, 2025 - 14:12 UTC

Update

Our ability to provide support via chat is impacted, but you can continue to receive support via phone. This is due to an outage by one of our partners, Cloudflare. Our team is actively monitoring the issue for resolution.
Posted Nov 18, 2025 - 13:34 UTC

Identified

Our ability to provide support via chat is impacted, but you can continue to receive support via phone. Our team is aware of the issue and is actively working to correct it.
Posted Nov 18, 2025 - 13:24 UTC

Investigating

Our ability to provide support via chat, text or phone is impacted. Our team is aware of the issue and is actively working to correct it.
Posted Nov 18, 2025 - 13:17 UTC
This incident affected: Dashboard, Mobile, Spend Management, Bill Pay, and Home Page.