Degraded Dashboard Performance

Incident Report for Brex

Resolved

Some customers who have the Apollo Client Devtools Chrome extension installed may experience poor dashboard performance due to a recent issue with the extension. Please disable the extension if you encounter slowness.
Posted 10 months ago. May 30, 2024 - 19:56 UTC

Investigating

Some customers are experiencing an issue with dashboard performance. We are investigating and will update this page as we resolve the issue.
Posted 10 months ago. May 30, 2024 - 19:14 UTC
This incident affected: Dashboard.