Banking transaction approval tasks are failing to load

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Jan 27, 2026 - 17:18 UTC

Identified

Users are experiencing issues with loading banking transactions for review. The team has identified the issue and is working on a fix.
Posted Jan 27, 2026 - 17:10 UTC
This incident affected: Banking.