Trust Portal (trust-portal.brex.com) is down

Incident Report for Brex

Resolved

The Brex Trust Portal has been up and running again since 12:00pm PT.
Posted Sep 02, 2026 - 01:56 UTC

Monitoring

The site has been restored.
Posted Sep 01, 2026 - 19:20 UTC

Investigating

The Brex trust portal is currently unavailable, we are investigating the issue.
Posted Sep 01, 2026 - 17:48 UTC