Unable to login to Brex mobile app

Incident Report for Brex

Resolved

This issue is now resolved.
Posted Aug 27, 2025 - 02:26 UTC

Monitoring

We have identified the issue and have made a fix.
Posted Aug 27, 2025 - 02:25 UTC

Investigating

We are currently investigating this issue,
Posted Aug 27, 2025 - 02:23 UTC
This incident affected: Mobile.