Transaction statuses on your Accounting pages may be out of date, causing some transactions to appear in the wrong tab.

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Sep 15, 2026 - 23:20 UTC

Identified

Your changes are still being saved, and we're working on a fix.
Posted Sep 15, 2026 - 20:12 UTC
This incident affected: Spend Management.