Users are unable to access the dashboard

Incident Report for Brex

Resolved

Dashboard access has been restored for all users.
Posted Jun 11, 2025 - 13:07 UTC

Monitoring

Dashboard access is being restored for users.
Posted Jun 11, 2025 - 12:43 UTC

Investigating

We are investigating issues with the dashboard unable to load for some users.
Posted Jun 11, 2025 - 12:35 UTC
This incident affected: Dashboard.