Intermittent Reimbursement Submission Issues

Incident Report for Brex

Resolved

This incident has been resolved.
Posted 11 months ago. May 16, 2024 - 18:14 UTC

Update

A fix has been implemented and we are monitoring the results.
Posted 11 months ago. May 16, 2024 - 17:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 11 months ago. May 16, 2024 - 17:37 UTC

Investigating

Some customers are experiencing an issue with submitting reimbursements. We are investigating and will update this page as we resolve the issue.
Posted 11 months ago. May 16, 2024 - 15:12 UTC
This incident affected: Spend Management.