Slow loading of activity logs and audit trail

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Jun 04, 2026 - 22:01 UTC

Monitoring

We have identified the issue and have a fix in place.
Posted Jun 04, 2026 - 21:37 UTC

Investigating

Users may experience slow load times or timeouts when viewing activity on expenses, bills, users, cards in addition to their account audit trail. Other parts of the product remain unaffected. We'll share an update as soon as we have more information.
Posted Jun 04, 2026 - 21:23 UTC
This incident affected: Dashboard.