Budgets, Expenses, and Sign-up Request Availability
Incident Report for Brex
Resolved
This incident has been resolved.
Posted Aug 25, 2022 - 17:26 UTC
Monitoring
Some customers experienced an issue with Budgets, Expenses, and Sign-up Requests this morning. A fix has been implemented and we are monitoring the results to ensure a seamless customer experience.
Posted Aug 25, 2022 - 16:45 UTC
This incident affected: Money movement: card authorization and Dashboard.