Customers are unable to load the Brex Dashboard after sign-in
Incident Report for Brex
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 17:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2024 - 14:37 UTC
Investigating
Some customers are experiencing an issue with seeing a blank screen after login. We are investigating and will update this page as we resolve the issue.
Posted Nov 28, 2024 - 14:28 UTC
This incident affected: Dashboard.