Spend Management and BillPay Partial Outage
Incident Report for Brex
Resolved
A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2024 - 02:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2024 - 01:53 UTC
Investigating
Some customers are experiencing an issue with Bill Pay and Spend Management. We are investigating and will update this page as we resolve the issue.
Posted Feb 02, 2024 - 01:31 UTC
This incident affected: Spend Management and Bill Pay.