Dashboard Availability
Incident Report for Brex
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 14:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2023 - 14:17 UTC
Investigating
Some customers are experiencing an issue with accessing Dashboard. We are investigating and will update this page as we resolve the issue.
Posted Sep 07, 2023 - 13:52 UTC
This incident affected: Dashboard.