Dashboard and mobile unavailable

Incident Report for Brex

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 21:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 21:29 UTC

Investigating

Some customers are experiencing an issue with accessing the Dashboard and the Brex mobile app. We are investigating and will update this page as we resolve the issue.
Posted Apr 11, 2025 - 21:27 UTC
This incident affected: Dashboard and Mobile.