Notification delays

Incident Report for Brex

Resolved

We’ve resolved the issue affecting notifications and the Tasks page. All services are operating normally.
Posted Jul 30, 2026 - 18:11 UTC

Identified

We have identified the issue and are working on a fix.
Posted Jul 30, 2026 - 17:34 UTC

Investigating

Customers may experience delays receiving notifications, as well as delays or errors when loading the Tasks page or resetting authentication methods such as passwords or 2FA. Our team is investigating and working to restore normal service.
Posted Jul 30, 2026 - 17:04 UTC
This incident affected: Money movement: card authorization and Dashboard.