Dashboard Partial Outage

Incident Report for Brex

Resolved

We've resolved the issue and all affected functionality has been restored.
Posted Aug 27, 2025 - 16:04 UTC

Monitoring

We've identified the root cause and have corrected it. We are monitoring the affected functionalities that have been restored.
Posted Aug 27, 2025 - 15:55 UTC

Investigating

Some customers are experiencing issues loading expenses, wallet and home. Our team is aware of the issue and is actively working to correct it.
Posted Aug 27, 2025 - 14:39 UTC
This incident affected: Dashboard.