Brex Travel Outage

Incident Report for Brex

Resolved

We have resolved the issue affecting the ability to book and manage trips. Users can now continue using Brex Travel.
Posted Jun 13, 2026 - 07:53 UTC

Investigating

We are currently investigating an issue preventing trip booking and management.
Posted Jun 13, 2026 - 05:21 UTC
This incident affected: Brex Travel.