Booking using rewards points on Brex travel experiencing issues

Incident Report for Brex

Resolved

Systems related to rewards bookings are now stable. Marking this incident as resolved.
Posted May 23, 2025 - 20:34 UTC

Monitoring

We've mitigated the issue and are now monitoring service health.
Posted May 23, 2025 - 19:54 UTC

Identified

We identified that there are issues booking using rewards points on Brex travel. We've identified a fix and are working towards resolution.
Posted May 23, 2025 - 19:31 UTC
This incident affected: Brex Travel.