Account Verification Outage

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Sep 04, 2025 - 06:08 UTC

Monitoring

We have resolved the issue and are monitoring.
Posted Sep 03, 2025 - 23:26 UTC

Investigating

We are investigating an issue preventing completion of the ID verification process as part of account verification.
Posted Sep 03, 2025 - 22:36 UTC
This incident affected: Home Page.