Scheduled Maintenance

Incident Report for Brex

Resolved

Maintenance is now complete, and all systems are back online.
Posted Nov 23, 2025 - 10:18 UTC

Monitoring

We have begun the scheduled maintenance of our systems. Expected downtime is ~3 mins.
Posted Nov 23, 2025 - 09:35 UTC