Travel service disruption

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Oct 07, 2025 - 23:39 UTC

Investigating

We are experiencing a service disruption impacting Travel. Our team is actively working to resolve the issue as soon as possible.
Posted Oct 07, 2025 - 23:12 UTC
This incident affected: Brex Travel.