Issues with reviewing Spend Limit requests

Incident Report for Brex

Resolved

A fix was implemented and customers are now able to review spend limit and limit increase requests as expected.
Posted May 14, 2025 - 17:55 UTC

Update

Some users are experiencing errors when trying to review new spend limit or spend limit increase requests in the Tasks page. The team has identified the issue and is working to resolve.
Posted May 14, 2025 - 17:09 UTC

Identified

Some suers are experiencing errors when trying to review new spend limit or spend limit increase requests in the Tasks page.
Posted May 14, 2025 - 17:07 UTC
This incident affected: Dashboard.