Login Issues
Incident Report for Brex
Resolved
The issue has been resolved and Dashboard and Mobile are fully operational
Posted May 31, 2024 - 22:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2024 - 22:28 UTC
Investigating
Some customers may not be able to see their BBAs
Posted May 31, 2024 - 22:18 UTC
Update
A fix has been implemented and we are monitoring the results.
Posted May 31, 2024 - 22:12 UTC
Monitoring
Some customers were experiencing an issue with Dashboard, Mobile. This issue has been resolved and we are monitoring for any further issues.
Posted May 31, 2024 - 22:09 UTC
Update
Some customers are experiencing an issue with Dashboard, Mobile. We are investigating and will update this page as we resolve the issue.
Posted May 31, 2024 - 21:54 UTC
Update
Some customers are experiencing an issue with Dashboard and the mobile application. We are investigating and will update this page as we resolve the issue.
Posted May 31, 2024 - 21:53 UTC
Investigating
Some customers are experiencing issues logging into the dashboard. We are investigating and will update this page as we resolve the issue.
Posted May 31, 2024 - 21:48 UTC
This incident affected: Dashboard and Mobile.